Q1:通达信公式编写

算术函数IF(逻辑判断)语句相当于我们平时所说的”如果.....那么“。
IF---根据条件求不同的值.
用法:
IF(X,A,B)若X不为0则返回A,否则返回B
例如:IF(CLOSE>OPEN,HIGH,LOW)表示该周期收阳则返回最高值,否则返回最低值
时间函数HOUR---小时
取得该周期的小时数.
用法:
HOUR
函数返回有效值范围为(0-23),对于日线及更长的分析周期值为0;
MINUTE---分钟
取得该周期的分钟数.
用法:
MINUTE
函数返回有效值范围为(0-59),对于日线及更长的分析周期值为0

Q2:通达信 函数 if 参数自调用:

TT:IF(A=1 AND B=0,1,IF(A=0 AND B=1,-1,DRAWNULL));

Q3:请问通达信中的IF语句怎么编写

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1);
D:SMA(K,3,1);
J:=3*K-2*D;
IF(J>100,100,IF(J<0,0,J));
如法炮制

Q4:通达信 if 函数 LOW_NUM:=IF(LOW<REF(LLV(LOW,N),1),-1,...

首先这应该是一段代码而非完整的代码
LOW_NUM:=IF(LOW<REF(LLV(LOW,N),1),-1,0)
单看这一段代码跟真假没有关系,这句代码翻译成白话就是
当今日最低价创N日新低的时候输出-1 否则输出0
如果想判断真假根本不用IF函数,用IF函数是多此一举
例如下面的代码
LOW<REF(LLV(LOW,N),1);
翻译成白话就是当今日最低价创N日新低的时候结果成立为真时输出值是1条件不成立结果为假时输出值会为0.
因为只有一段代码非完整的公式代码,
所以不清楚IF判断完输出的-1是什么含义,用于做什么.

Q5:编制选股中的FILTER怎样使用?

DIFF:=ema(CLOSE,12) - ema(CLOSE,26);
dea:=ema(DIFF,9);
MACD:=2*(DIFF-dea);
A:=IF(cross(0,dea),1,0);
A1:=IF(DIFF<0 AND cross(DIFF,dea),1,0);
SS:=IF(A,SUM(A1,0),0);
SSB:=HHV(SS,0);
sss:=SUM(A1,0);
W底选股:sss-SSB=2 AND sss>REF(sss,1);
N:=20;

Q6:通达信的FILTER算不算未来函数

引用函数FILTER(过滤)不属于未来函数。